FIX MASALAH: Server Anda menjalankan versi PHP namun WordPress 5.1.6 3.2.1 5.2.4 Membutuhkan Sedikitnya.

Pemberitahuan untuk semua tidak dikenal bahwa untuk memasang atau melakukan meningkatkanBPK ke versi yang lebih baru dari 3.2Hal ini diperlukan bahwa diinstal versi yang lebih baru dari 5.2.4.

Jika server menginstal versi PHP tua dari 5.2.4, menginstal versi Wordpress 3.2.1akan muncul error / Pesan "Server anda menjalankan PHP versi WordPress 5.1.6 3.2.1 Tapi Membutuhkan Sedikitnya 5.2.4".
Masalahnya dapat diselesaikan dengan sangat sederhana dengan upgrade PHP, tapi sebelum melakukannya beberapa hal yang harus dipertimbangkan. Pertama, meng-upgrade PHP hosting dikeluarkan dari saham. Sehingga Anda dapat melakukan upgrade Anda harus memiliki akses administrator ke server (Dedicated Server atau VPS). Dalam kedua, sebelum upgrade harus mendokumentasikan dan menyadari bahwa versi baru dari PHP tidak memberikan kesalahan situs lain host pada server yang.

untuk sistem operasi yang digunakan untuk server web (Agreart dan / WHM) Akan menunjukkan kepada Anda bagaimana untuk melakukan upgrade ke PHP pada CentOS 5.2.10.x 5 32-bit.

Meng-upgrade PHP pada CentOS 5.1.x 5.2.x ke 5.x 32-bit

1. Memeriksa paket / modul terpasang PHP (misalnya php-mcrypt) di samping paket standar. Jika mereka ada, akan dihapus atau actuzlizate.

Memeriksa paket diinstal:

rpm-qa | grep php

old_php_version

2. Untuk menambah repositori ekstra Wajib meningkatkan'S versi PHP.

nano / etc / yum.repos.d / CentOS-Testing.repo

File baru (CentOS-Testing.repo) Akan menambahkan baris berikut (copy / paste):

[C5-testing]
name = CentOS-Pengujian 5
http://dev.centos.org/centos/ baseurl = $ releasever / pengujian / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X untuk menyimpan file CentOS-Testing.repo.

3. Pembaruan PHP melalui yum:

yum pembaruan

4. Restart / httpd :

layanan httpd restart

Setelah me-restart httpd dan memeriksa versi paket-paket terinstall:

new_php_version

Memeriksa kesalahan modul / paket:

php-v

- PHP Tingkatkan / CentOS 32-bit (i386).

FIX MASALAH: Server Anda menjalankan versi PHP namun WordPress 5.1.6 3.2.1 5.2.4 Membutuhkan Sedikitnya.

Tentang Penulis

Stealth LP

Pendiri dan editor Pengaturan StealthDalam tanggal 2006.
Pengalaman pada sistem operasi Linux (khususnya CentOS), Mac OS X, Windows XP> Windows 10 dan WordPress (CMS).

Tinggalkan Komentar

Situs ini menggunakan Akismet untuk mengurangi spam. Pelajari bagaimana data komentar Anda diproses.